DIY装机联盟-电脑故障排除|装机指南|硬件|配置|电脑知识

DIY装机联盟-电脑故障排除|装机指南|硬件|配置|电脑知识

http://www.jinanshengke.com

菜单导航

细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?

作者: 庄吉 发布时间: 2019年10月19日 14:58:36

我们曾多次提到交换机的配置,有部分朋友反映有点深了,有些内容不懂,今天我们就从基础到深入来了解网络间如何才能互通,如何才能不通,以案例的方式来详细讲解,一文了解清楚vlan的使用与配置,方便后面应用于项目中。

因为根据弱电VIP技术群朋友反映,华为交换机使用的比较多,所以本次以华为交换机为例,如果大家以前对vlan了解不深,那么这篇文章却是可以很好入门与深入。

一、什么样的网络才能互通

通常情况下,两台电脑如何能才互通呢?如何才能不能互相访问呢?

最简章方法就是利用网段来解决,我们来举例。

细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?

1、两台电脑不能互相访问

假设:

PC1 ip地址:192.168.1.1/24

PC2 ip地址:192.168.2.1/24

要测试PC1和PC2的连通性:最简单的方法就是用PC1去PingPC2,查看Ping的结果。

细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?

很明显ping不通,PC1和PC2的ip在不同的网段,不能ping通。

那么什么样的情况能ping通呢?

2、如何才能互访

假设:

PC1的ip地址:192.168.1.1/24

PC2的IP地址:192.168.1.2/24

PC3的ip地址: 192.168.1.3/24

都在同一个网段内,用测试pc1是否能互访pc2与pc3,直接用pc1去ping pc2与pc3就行。

pc1去ping pc2

细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?

pc1去ping pc3

细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?

很明显,两个都是可以ping通的,因为PC1-PC5在同一个网段内,使用是相同的网关。

那么问题来了,如何让同一个网段的ip不能互通呢?如何让不同网段ip又能互通

?这里面我们就需要引进vlan了。

二、划分vlan,实现网络的互访与阻绝

上面我们已经演示了网络最简单的互通与不通的情况,在没有其它设置的情况下,同一个网段的ip地址,能互通,不同的网段的ip地址不能互通。而在实际项目中,并不是这么简单的,我们来看下不同vlan与不同网段之间的互通与阻绝如何实现。

还是这个拓扑图:

细讲交换机配置,什么样的网络能互通,什么样的网络不能互通?

假设:

PC1的ip地址:192.168.1.1/24 连接LSW1交换机端口Ethernet 0/0/1

PC2的IP地址:192.168.1.2/24 连接LSW1交换机端口Ethernet 0/0/2

PC3的ip地址: 192.168.1.3/24 连接LSW1交换机端口Ethernet 0/0/3

PC4的ip地址: 192.168.1.4/24 连接LSW2交换机端口Ethernet 0/0/1

现在要让pc1与pc2互访,p1与pc3不能互通,pc1与pc4也不能互访,如何来配置交换机?(今天我们就以华为交换机为例)。

交换机配置(以华为交换机为例)

1、配置LSW1

<Huawei>system-view //进入系统视图

[Huawei]sysname sw1 //给交换机命名

[sw1]vlan 10 //创建VLAN10

[sw1-vlan10]vlan 20 //创建VLAN20

[sw1-vlan20]display vlan //显示VLAN信息

[sw1-vlan20]quit //退回上一级视图

[sw1]interface Ethernet 0/0/1 //进入以太网接口0/0/1

[sw1-Ethernet0/0/1]port link-type access //配置接口类型为Access

[sw1-Ethernet0/0/1]port default vlan 10 //分配接口给VLAN10

[sw1-Ethernet0/0/1]quit //退回上一级视图

[sw1]interface Ethernet 0/0/2 //进入以太网接口0/0/2

[sw1-Ethernet0/0/2]port link-type access //配置接口类型为Access

[sw1-Ethernet0/0/2]port default vlan 10 //分配接口给VLAN10

[sw1-Ethernet0/0/2]quit //退回上一级视图

[sw1]interface Ethernet 0/0/3 //进入以太网接口0/0/3

[sw1-Ethernet0/0/3]port link-type access //配置接口类型为Access

[sw1-Ethernet0/0/3]port default vlan 20 //分配接口给VLAN20

[sw1-Ethernet0/0/3]display vlan //显示VLAN信息

小结:在LSW1中,把pc1与pc2分配在了vlan10,把pc3分配到了vlan20中。

2、LSW2交换机配置

命令与上面类似,就不一 一注释了,多看几篇就很容易理解。

<Huawei>system-view

[Huawei]sysname sw2

[sw2]vlan 10 //批量创建VLAN

[sw2]display vlan

[sw2]interface Ethernet 0/0/1 //进入pc4的以太网接口0/0/1

[sw2-Ethernet0/0/1]port link-type access //配置接口类型为Access

[sw2-Ethernet0/0/1]port default vlan 10 //分配接口给VLAN10

[sw2-Ethernet0/0/2]display vlan

在LSW2中,主要是把pc4划分给了vlan10

3、验证vlan

a、测试PC1和PC2的连通性。

本文地址:http://www.jinanshengke.com/wlzs/781.html

请遵守互联网相关规定,不要发布广告和违法内容